aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-distro
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-04-11 21:49:45 +0100
committerKeith Maxwell <keith.maxwell@gmail.com>2020-04-11 21:49:45 +0100
commit8121c0873d2b496440487be5cb3e5e499b60b8ae (patch)
treea62b8a687926aa37d7ed3c315f8976071d7011b2 /community/py3-distro
parentee17634eb81b78f023f7e7acbc4102160ad68939 (diff)
downloadaports-8121c0873d2b496440487be5cb3e5e499b60b8ae.tar.bz2
aports-8121c0873d2b496440487be5cb3e5e499b60b8ae.tar.xz
community/py3-distro: add missing dependency
Before this change: $ sudo apk add py3-distro ✂ $ distro --help Traceback (most recent call last): File "/usr/bin/distro", line 6, in <module> from pkg_resources import load_entry_point ModuleNotFoundError: No module named 'pkg_resources' After this change: $ sudo apk add py3-distro ✂ $ distro --help usage: distro [-h] [--json] ✂ The above commands were run inside docker-abuild with `dabuild sh`. The change is required because `/usr/bin/distro` includes the line: from pkg_resources import load_entry_point That means that py3-setuptools is required at runtime: $ python3 -c 'import pkg_resources; print(pkg_resources.__file__)' /usr/lib/python3.8/site-packages/pkg_resources/__init__.py $ apk info -q -W /usr/lib/python3.8/site-packages/pkg_resources/__init__.py py3-setuptools
Diffstat (limited to 'community/py3-distro')
-rw-r--r--community/py3-distro/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/community/py3-distro/APKBUILD b/community/py3-distro/APKBUILD
index daa1e65371..5f1afe2d2d 100644
--- a/community/py3-distro/APKBUILD
+++ b/community/py3-distro/APKBUILD
@@ -3,14 +3,13 @@
pkgname=py3-distro
_pkgname=distro
pkgver=1.5.0
-pkgrel=0
+pkgrel=1
pkgdesc="A Linux OS platform information API"
options="!check" # Some tests fail
url="https://github.com/nir0s/distro"
arch="noarch"
license="Apache-2.0"
-depends="python3"
-makedepends="py3-setuptools"
+depends="python3 py3-setuptools"
checkdepends="py3-pytest py3-pytest-cov"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver