aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-django-crispy-forms
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-26 19:55:54 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-09 08:03:08 -0300
commit51cf42c979ac2ceff213198f201112857b22b46b (patch)
tree17f25e0c52d5d397796636573c4eeff430f4f19c /community/py3-django-crispy-forms
parent0f688885f04441c7034b2d99310ee12501fbecfa (diff)
downloadaports-51cf42c979ac2ceff213198f201112857b22b46b.tar.bz2
aports-51cf42c979ac2ceff213198f201112857b22b46b.tar.xz
community/py3-django-crispy-forms: move from testing
Diffstat (limited to 'community/py3-django-crispy-forms')
-rw-r--r--community/py3-django-crispy-forms/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-django-crispy-forms/APKBUILD b/community/py3-django-crispy-forms/APKBUILD
new file mode 100644
index 0000000000..073ddab1ef
--- /dev/null
+++ b/community/py3-django-crispy-forms/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py3-django-crispy-forms
+_pkgname=django-crispy-forms
+pkgver=1.7.2
+pkgrel=0
+pkgdesc="Dry Django forms"
+options="!check" # No testsuite
+url="https://github.com/django-crispy-forms/django-crispy-forms"
+arch="noarch"
+license="MIT"
+depends="py3-django"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_pkgname/django-crispy-forms/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-django-crispy-forms" # Backwards compatibility
+provides="py-django-crispy-forms=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py --quiet build
+}
+
+package() {
+ python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="1e8d8e6b71675380ec59b9a4375b4144c222f5bc765e4300c31787d52195add88c974c6c8ae09e71e277d4ce552928e47384b674464a04ab74adb6b8dbe8faa2 py3-django-crispy-forms-1.7.2.tar.gz"