aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-elasticsearch
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-03-03 23:21:19 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-09 16:21:16 -0300
commit31be30072ea32b11fece8037dc82ba4b84f3db61 (patch)
tree50dc2feaf6a4f07c0ba214c53231609a3ee1f0a6 /community/py3-elasticsearch
parent3f129e66cd38dcee69b388697f64c92b187191cd (diff)
downloadaports-31be30072ea32b11fece8037dc82ba4b84f3db61.tar.bz2
aports-31be30072ea32b11fece8037dc82ba4b84f3db61.tar.xz
community/py3-elasticsearch: move from testing
Diffstat (limited to 'community/py3-elasticsearch')
-rw-r--r--community/py3-elasticsearch/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-elasticsearch/APKBUILD b/community/py3-elasticsearch/APKBUILD
new file mode 100644
index 0000000000..37d3501da5
--- /dev/null
+++ b/community/py3-elasticsearch/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=py3-elasticsearch
+_pkgname=elasticsearch-py
+pkgver=7.1.0
+pkgrel=0
+pkgdesc="Official Python low-level client for Elasticsearch"
+url="https://elasticsearch-py.readthedocs.io/"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-urllib3"
+checkdepends="py3-requests py3-nose py3-coverage py3-mock py3-yaml py3-nosexcover"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/elastic/elasticsearch-py/archive/$pkgver.tar.gz"
+builddir="$srcdir/"$_pkgname-$pkgver
+
+replaces="py-elasticsearch" # Backwards compatibility
+provides="py-elasticsearch=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="af6dc6f200190e57d37d5c771da6cf9b3cbeee8f4bbffbe0b9466fe88496b9c45d44ef40c2d5379e4fa9cc54ce61c46b35a578e3ae99b82afeacd132bf2c6ad6 py3-elasticsearch-7.1.0.tar.gz"