aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-execnet
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-31 01:59:01 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 01:59:01 -0300
commit4109d4cb585571d4404156424cfefb72a712e780 (patch)
treecb1c36447421a0832196aeacfc73532ef5cc2654 /community/py3-execnet
parent362039e84dbfef581b034fbb154e38439225e4e0 (diff)
downloadaports-4109d4cb585571d4404156424cfefb72a712e780.tar.bz2
aports-4109d4cb585571d4404156424cfefb72a712e780.tar.xz
community/py3-execnet: rename from py-execnet
Diffstat (limited to 'community/py3-execnet')
-rw-r--r--community/py3-execnet/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/community/py3-execnet/APKBUILD b/community/py3-execnet/APKBUILD
new file mode 100644
index 0000000000..db5a30f5f2
--- /dev/null
+++ b/community/py3-execnet/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
+# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
+pkgname=py-execnet
+_pkgname=execnet
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="execnet: rapid multi-Python deployment"
+url="https://github.com/pytest-dev/execnet"
+arch="noarch"
+license="MIT"
+depends="py-apipkg"
+# tests for py-gevent are broken, jython is missing in repo, eventlet is part
+# of testing
+checkdepends="pytest py-py"
+makedepends="py3-setuptools py-setuptools py-setuptools_scm"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ mv $builddir/doc/example/conftest.py $builddir
+ python2 -m pytest
+ python3 -m pytest
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="5cc77f534d6a4966250a8494c53231dea938044268d3f81efd77ed20f5548ac167aa20e1e54fc3307828ba2937f5b1af44d2e8412110998b6016125fcf984c56 execnet-1.7.0.tar.gz"