aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-eyed3
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-30 12:09:44 +0200
committerprspkt <prspkt@protonmail.com>2019-03-30 12:09:44 +0200
commit5581babf22091528fbc5e2e19be9b7230fd8e816 (patch)
tree0f88663d869f79bf269f7a16db0350cceb2bd0ed /community/py3-eyed3
parentb4b1ce6f670c17f23010152e20ddb10dfdfd7278 (diff)
downloadaports-5581babf22091528fbc5e2e19be9b7230fd8e816.tar.bz2
aports-5581babf22091528fbc5e2e19be9b7230fd8e816.tar.xz
community/py-eyed3: rename to py3-eyed3
Diffstat (limited to 'community/py3-eyed3')
-rw-r--r--community/py3-eyed3/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py3-eyed3/APKBUILD b/community/py3-eyed3/APKBUILD
new file mode 100644
index 0000000000..3fed224ae2
--- /dev/null
+++ b/community/py3-eyed3/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-eyed3
+_pkgname=eyeD3
+pkgver=0.8.10
+pkgrel=0
+pkgdesc="ID3 tag editor in Python"
+url="http://eyed3.nicfit.net/"
+arch="noarch"
+license="GPL-3.0-or-later"
+provides="py-eyed3" # for backwards compatibility
+replaces="py-eyed3=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3 py3-magic py3-six"
+depends_dev=""
+makedepends="py3-setuptools python3-dev"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="85502d593d803dc7843349a0787ebebfd8c1ee56e94b14d569b90aab0cd42496be293a4a92a567f86208e614ba862b889ae343431795abe142b43fc703a98b79 eyeD3-0.8.10.tar.gz"