aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fontmath
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-01-04 18:12:14 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-01-04 22:29:56 +0100
commitc7268e209f865f275eaa1270b894edc011d41d39 (patch)
tree53c7423c833437ec7800ef8eeb57f6b0729c9d0a /community/py3-fontmath
parentf062af507479fd92d4b6a9d54fd50332591e0aa6 (diff)
downloadaports-c7268e209f865f275eaa1270b894edc011d41d39.tar.bz2
aports-c7268e209f865f275eaa1270b894edc011d41d39.tar.xz
community/py3-fontmath: move from testing
Diffstat (limited to 'community/py3-fontmath')
-rw-r--r--community/py3-fontmath/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-fontmath/APKBUILD b/community/py3-fontmath/APKBUILD
new file mode 100644
index 0000000000..31252198bf
--- /dev/null
+++ b/community/py3-fontmath/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-fontmath
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="A set of objects for performing math operations on font data"
+url="https://github.com/robotools/fontMath"
+arch="noarch"
+license="MIT"
+depends="py3-fonttools python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+options="!check" # https://github.com/robotools/fontMath/issues/178
+source="https://files.pythonhosted.org/packages/source/f/fontMath/fontMath-$pkgver.zip"
+builddir="$srcdir/fontMath-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c4f2f5c8a994b3ae3339e648e13f36f38fd075d01c5955ab896f73cdd29791e88c018c3f35590428c0756e301784b566fee1e71e19a65921ea27584b826e0327 fontMath-0.5.2.zip"