aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gitlab
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-04-11 17:29:43 +0100
committerKeith Maxwell <keith.maxwell@gmail.com>2020-04-11 17:29:43 +0100
commite383ff1baa575088b36865028e11519d15bc842b (patch)
treef830fff0d5cded5cea8a84b89546f28a07de3488 /community/py3-gitlab
parent55bea36deefaba9f84d053bd173a09f2ebc710d2 (diff)
downloadaports-e383ff1baa575088b36865028e11519d15bc842b.tar.bz2
aports-e383ff1baa575088b36865028e11519d15bc842b.tar.xz
community/py3-gitlab: upgrade to 2.2.0
Enable 35 tests in six files; all of the tests that don't require httmock.
Diffstat (limited to 'community/py3-gitlab')
-rw-r--r--community/py3-gitlab/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/community/py3-gitlab/APKBUILD b/community/py3-gitlab/APKBUILD
index e8963f4d70..41976174d2 100644
--- a/community/py3-gitlab/APKBUILD
+++ b/community/py3-gitlab/APKBUILD
@@ -2,10 +2,9 @@
# Maintainer:
pkgname=py3-gitlab
_pkgname=python-gitlab
-pkgver=2.1.2
+pkgver=2.2.0
pkgrel=0
pkgdesc="v4 GitLab API compliant library and cmdline tool"
-options="!check" # Requires unpackaged 'httmock'
url="https://github.com/python-gitlab/python-gitlab"
arch="noarch"
license="LGPL-3.0-or-later"
@@ -20,11 +19,18 @@ build() {
}
check() {
- py.test-3
+ # Ignore tests that require unpackaged 'httmock'
+ python3 -m pytest \
+ --ignore gitlab/tests/test_gitlab.py \
+ --ignore gitlab/tests/test_mixins.py \
+ --ignore gitlab/tests/objects/test_application.py \
+ --ignore gitlab/tests/objects/test_commits.py \
+ --ignore gitlab/tests/objects/test_groups.py \
+ --ignore gitlab/tests/objects/test_projects.py
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="9d139a4fc21b02f9d0640fcd88528a42a51c29ab20802f476744b30cc85c174f91c2514f8aca0d5b0b45b494510e2a606a5e7a7edbc68cda7bdcd0636669e6ea python-gitlab-2.1.2.tar.gz"
+sha512sums="bdf34e4b9e45f5767faf81d52caf1b800d931a105940bb80b1e58cc8efc34a319196a6aa437d49215f0f4ff24359cc2497853486698a23413b2bb3dfe169e5e3 python-gitlab-2.2.0.tar.gz"