aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gunicorn
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-01-09 10:40:52 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-01-09 11:01:27 +0100
commit4852d8f2528acaa3118c8bc49409454d13154df1 (patch)
treef20b060ce464651b82d2cd584638294be4bb2eed /community/py3-gunicorn
parent39a90c66a57cc652be19f48a18c28cda672698e5 (diff)
downloadaports-4852d8f2528acaa3118c8bc49409454d13154df1.tar.bz2
aports-4852d8f2528acaa3118c8bc49409454d13154df1.tar.xz
community/py3-gunicorn: move from testing
Only required by testing/nextbox.
Diffstat (limited to 'community/py3-gunicorn')
-rw-r--r--community/py3-gunicorn/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/py3-gunicorn/APKBUILD b/community/py3-gunicorn/APKBUILD
new file mode 100644
index 0000000000..f26240161e
--- /dev/null
+++ b/community/py3-gunicorn/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-gunicorn
+_pkgname=gunicorn
+pkgver=19.9.0
+pkgrel=1
+pkgdesc="a Python WSGI HTTP Server"
+url="https://github.com/benoitc/gunicorn/"
+arch="noarch"
+license="MIT"
+depends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/benoitc/$_pkgname/archive/${pkgver}.tar.gz"
+
+builddir="${srcdir}/${_pkgname}-${pkgver}"
+
+options="!check" # py3-pytest-cov is in community
+
+replaces=py-gunicorn # Backwards compatibility
+provides=py-gunicorn=$pkgver-r$pkgrel # Backwards compatibility
+
+prepare() {
+ default_prepare
+ # use installed checkdepends instead of fetching from pypi
+ sed -i \
+ -e 's/==.*//' \
+ -e '/cover/d' \
+ requirements_test.txt
+}
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8d1ff775dd5c1abb8bb4c80aecacb544382e38d101f105fd0fd7eb6bf98ecb663dd533d16e7b1741d6e5ef0eb12a707ab90e0a7751356e625725f076b4dc1a30 gunicorn-19.9.0.tar.gz"