aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hglib/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 17:38:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 21:59:48 -0300
commit8876377c33bfac787425f29605eef2fff6568b5b (patch)
tree6d0aeef588ae0544bb3e938e745455d1932fb56e /community/py3-hglib/APKBUILD
parent262dc61668c61a96062b460654d12bc28d15bce1 (diff)
downloadaports-8876377c33bfac787425f29605eef2fff6568b5b.tar.bz2
aports-8876377c33bfac787425f29605eef2fff6568b5b.tar.xz
community/py3-hglib: drop py2
Diffstat (limited to 'community/py3-hglib/APKBUILD')
-rw-r--r--community/py3-hglib/APKBUILD40
1 files changed, 11 insertions, 29 deletions
diff --git a/community/py3-hglib/APKBUILD b/community/py3-hglib/APKBUILD
index 1e59fa8a78..5873dafa3d 100644
--- a/community/py3-hglib/APKBUILD
+++ b/community/py3-hglib/APKBUILD
@@ -1,52 +1,34 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
-pkgname=py-hglib
+pkgname=py3-hglib
_pkgname=python-hglib
pkgver=2.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="A fast and convenient interface to Mercurial's command server"
+# hglib.error.CommandError: (255, b'', b'abort: creating obsolete markers is not enabled on this repo')
+options="!check"
url="https://pypi.python.org/pypi/python-hglib"
arch="noarch"
license="MIT"
-makedepends="mercurial python2-dev py-setuptools python3-dev"
-checkdepends="py-nose"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+depends="python3"
+makedepends="mercurial py3-setuptools"
+checkdepends="py3-nose"
source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-hglib" # Backwards compatibility
+provides="py-hglib=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
- python2 test.py
python3 test.py
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="3895c38d07cf3d66c711ad37d312535d233430938c536c6e8e548c34bbe3deb5a1f3cc5ad05151e28cac86657d7cdb4bc0a55a1ea5f78aa42856b694cfbe8c97 python-hglib-2.6.1.tar.gz"