aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hglib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 17:37:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 21:59:47 -0300
commit262dc61668c61a96062b460654d12bc28d15bce1 (patch)
treee5387764de1fc74f48e0b4f434f7092c174de431 /community/py3-hglib
parenta82482f2cafe1f675a760b180aef59b124d8eecd (diff)
downloadaports-262dc61668c61a96062b460654d12bc28d15bce1.tar.bz2
aports-262dc61668c61a96062b460654d12bc28d15bce1.tar.xz
community/py3-hglib: rename from py-hglib
Diffstat (limited to 'community/py3-hglib')
-rw-r--r--community/py3-hglib/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/py3-hglib/APKBUILD b/community/py3-hglib/APKBUILD
new file mode 100644
index 0000000000..1e59fa8a78
--- /dev/null
+++ b/community/py3-hglib/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=py-hglib
+_pkgname=python-hglib
+pkgver=2.6.1
+pkgrel=1
+pkgdesc="A fast and convenient interface to Mercurial's command server"
+url="https://pypi.python.org/pypi/python-hglib"
+arch="noarch"
+license="MIT"
+makedepends="mercurial python2-dev py-setuptools python3-dev"
+checkdepends="py-nose"
+subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 test.py
+ python3 test.py
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="3895c38d07cf3d66c711ad37d312535d233430938c536c6e8e548c34bbe3deb5a1f3cc5ad05151e28cac86657d7cdb4bc0a55a1ea5f78aa42856b694cfbe8c97 python-hglib-2.6.1.tar.gz"