aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-httplib2
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:48:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-02 01:43:47 +0000
commitaad2afe051973fa7fd6f4f9b83703c09445ff17c (patch)
tree4266144bb0c3984f784b0dd910d33fa98a72c353 /community/py3-httplib2
parentaad758e364da9a69d0d519b619cc6eb2c7d150f8 (diff)
downloadaports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.bz2
aports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.xz
community/py3-*: move from main/ and modernize
Diffstat (limited to 'community/py3-httplib2')
-rw-r--r--community/py3-httplib2/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-httplib2/APKBUILD b/community/py3-httplib2/APKBUILD
new file mode 100644
index 0000000000..532085771f
--- /dev/null
+++ b/community/py3-httplib2/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-httplib2
+_pkgname=httplib2
+pkgver=0.15.0
+pkgrel=0
+pkgdesc="Python3 HTTP client library"
+url="https://github.com/httplib2/httplib2"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-httplib2" # Backwards compatibility
+provides="py-httplib2=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="be6884238fee6c2a75093204fb3c760da33d5ac04ebbb86f6a09f48ec70d44d8dbfccfe20b5d9c72745f42afedaf56bb783200b982dd2853b6bc91922961d390 httplib2-0.15.0.tar.gz"