aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hyperlink
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-19 10:42:16 +0300
committerprspkt <prspkt@protonmail.com>2019-06-19 10:43:19 +0300
commit097fd5548431611092f95fecd0f30d2a581deabd (patch)
treea0c7a47a8a4d23fdbdb5741c4daa5498534d245b /community/py3-hyperlink
parent2ecacf8f32c2af5443f13fc677b16156115d5d8d (diff)
downloadaports-097fd5548431611092f95fecd0f30d2a581deabd.tar.bz2
aports-097fd5548431611092f95fecd0f30d2a581deabd.tar.xz
community/py3-hyperlink: move from testing
Diffstat (limited to 'community/py3-hyperlink')
-rw-r--r--community/py3-hyperlink/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-hyperlink/APKBUILD b/community/py3-hyperlink/APKBUILD
new file mode 100644
index 0000000000..f9b0c1fbc6
--- /dev/null
+++ b/community/py3-hyperlink/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-hyperlink
+_pkgname=hyperlink
+pkgver=19.0.0
+pkgrel=0
+pkgdesc="Python implementation of immutable URLs"
+url="https://github.com/python-hyper/hyperlink"
+arch="noarch"
+license="MIT"
+depends="py3-idna"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/"$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ py.test-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="5d5723bc0bd0c381edd3a9ef7bab3ba9ad4252027d5a4afa61e6cfff3e5b8457994b6dd36ecc356e638d41f797fe3367a3010249e0e77bee6e9e94336c1e7c2e hyperlink-19.0.0.tar.gz"