aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hypothesis
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-04 14:16:14 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-05 03:01:03 -0300
commit2bd7559e348fb199477ea479249fb804acbd28a9 (patch)
treee19d4147e0854b6fed60027e1e39cb93bb401127 /community/py3-hypothesis
parentfc88b62ac921093482b24af72630638e5ef1c530 (diff)
downloadaports-2bd7559e348fb199477ea479249fb804acbd28a9.tar.bz2
aports-2bd7559e348fb199477ea479249fb804acbd28a9.tar.xz
community/py3-hypothesis: rename from py-hypothesis
Diffstat (limited to 'community/py3-hypothesis')
-rw-r--r--community/py3-hypothesis/APKBUILD74
1 files changed, 74 insertions, 0 deletions
diff --git a/community/py3-hypothesis/APKBUILD b/community/py3-hypothesis/APKBUILD
new file mode 100644
index 0000000000..050ea07869
--- /dev/null
+++ b/community/py3-hypothesis/APKBUILD
@@ -0,0 +1,74 @@
+# Contributor: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py-hypothesis
+pkgver=4.34.0
+pkgrel=0
+pkgdesc="Advanced property-based (QuickCheck-like) testing for Python"
+url="https://hypothesis.works/"
+arch="noarch"
+license="MPL-2.0"
+_py2_deps="py2-attrs py-enum34"
+_py3_deps="py3-attrs"
+makedepends="$_py2_deps $_py3_deps py2-setuptools py3-setuptools"
+checkdepends="py2-coverage py2-pytest py2-tz py2-dateutil py2-mock
+ py3-pytest py3-coverage py3-tz py3-numpy py3-dateutil"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/hypothesis-python-$pkgver.tar.gz"
+builddir="$srcdir/hypothesis-hypothesis-python-$pkgver/hypothesis-python"
+
+prepare() {
+ cp -r "$builddir" "$builddir"-py2
+}
+
+build() {
+ python3 setup.py build
+ cd "$builddir"-py2
+ python2 setup.py build
+}
+
+check() {
+ # In python3 mock is actually unittest.mock
+ sed -e 's/from mock/from unittest.mock/' -i tests/cover/test_regressions.py
+ sed -e 's/from mock/from unittest.mock/' -i tests/cover/test_reflection.py
+
+ # Add variables that will be used by python to find the local
+ # hypothesis build
+ PY3PATH="$PWD/build/lib"
+
+ PYTHONPATH="$PY3PATH" python3 -m pytest tests/cover
+ PYTHONPATH="$PY3PATH" python3 -m pytest tests/py3
+ PYTHONPATH="$PY3PATH" python3 -m pytest tests/datetime
+ PYTHONPATH="$PY3PATH" python3 -m pytest tests/numpy
+
+ cd "$builddir"-py2
+ PY2PATH="$PWD/build/lib"
+ PYTHONPATH="$PY2PATH" python2 -m pytest tests/cover
+ PYTHONPATH="$PY2PATH" python2 -m pytest tests/py2
+ PYTHONPATH="$PY2PATH" python2 -m pytest tests/datetime
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ depends="$_py2_deps"
+ cd "$builddir"-py2
+ _py python2
+}
+
+_py3() {
+ depends="$_py3_deps"
+ cd "$builddir"
+ _py python3
+}
+
+_py() {
+ _python="$1"
+ pkgdesc="$pkgdesc (for $_python)"
+ depends="$depends $_python"
+ install_if="$pkgname=$pkgver-r$pkgrel $_python"
+ $_python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="c1bc3307048e7b9e818e6c709544ec5be2fb0f8109a5a49af7a320ea77c8da0d69cad6e0fd546723c866d674960f009f901b2d0299ac55930ac2ff8db378929d py-hypothesis-4.34.0.tar.gz"