aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-i3ipc/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-09 08:56:30 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-09 08:56:30 +0100
commitb08a407c1d942cf0445a40a5450038963f1e894e (patch)
treef661339ac81f592ca5f9c2e007067f7cfe37df17 /community/py3-i3ipc/APKBUILD
parent7e43c9cd64f6ddae478026067621bd7e034f2bfd (diff)
downloadaports-b08a407c1d942cf0445a40a5450038963f1e894e.tar.bz2
aports-b08a407c1d942cf0445a40a5450038963f1e894e.tar.xz
community/py3-i3ipc: move from testing
Diffstat (limited to 'community/py3-i3ipc/APKBUILD')
-rw-r--r--community/py3-i3ipc/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-i3ipc/APKBUILD b/community/py3-i3ipc/APKBUILD
new file mode 100644
index 0000000000..ac94b3823a
--- /dev/null
+++ b/community/py3-i3ipc/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-i3ipc
+pkgver=2.1.1
+pkgrel=0
+pkgdesc="An improved Python library to control i3wm and sway"
+options="!check" # Requires unpackaged 'asyncio'
+url="https://github.com/altdesktop/i3ipc-python"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-xlib"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/altdesktop/i3ipc-python/archive/v$pkgver.tar.gz"
+builddir="$srcdir/i3ipc-python-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="4a136cd13c76f10a15bce521ad83a5edae32a3952a1e2e3a029f8dbaf08a22343ef6b20babb77d765f28f192a991241ed24ce03467f9bddc844e1f9743c343ac py3-i3ipc-2.1.1.tar.gz"