aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-impacket
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 10:05:25 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 10:38:34 -0300
commitabeb75b1841b4e81107e765fddf77687793959db (patch)
tree39e10cf3202a7315a585e92831e28b25544d5645 /community/py3-impacket
parent2f5d92fea96a332181a0e4eddce37963aa69fbd4 (diff)
downloadaports-abeb75b1841b4e81107e765fddf77687793959db.tar.bz2
aports-abeb75b1841b4e81107e765fddf77687793959db.tar.xz
community/py3-impacket: upgrade to 0.9.19
Diffstat (limited to 'community/py3-impacket')
-rw-r--r--community/py3-impacket/APKBUILD50
1 files changed, 13 insertions, 37 deletions
diff --git a/community/py3-impacket/APKBUILD b/community/py3-impacket/APKBUILD
index 59a3b6a936..3b068b0f45 100644
--- a/community/py3-impacket/APKBUILD
+++ b/community/py3-impacket/APKBUILD
@@ -1,52 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-impacket
+pkgname=py3-impacket
_pkgname=impacket
-pkgver=0.9.15
-pkgrel=1
-pkgdesc="A collection of Python classes providing access to network packets"
+pkgver=0.9.19
+pkgrel=0
+pkgdesc="A collection of Python3 classes providing access to network packets"
url="http://code.google.com/p/impacket/"
arch="noarch"
license="Apache-2.0"
-depends=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages="py2-${pkgname/py-/}:_py2 $pkgname-doc"
+depends="python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-impacket" # Backwards compatibility
+provides="py-impacket=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
- install -Dm0644 "$builddir"/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
-}
-
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- _py python2
- replaces="$pkgname"
- depends="py2-asn1 py2-crypto"
-}
-
-doc() {
- cd "$builddir"
- mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
- mv impacket/testcases "$subpkgdir"/usr/share/doc/$pkgname
- mv README.md "$subpkgdir"/usr/share/doc/$pkgname
- install -Dm0644 LICENSE "$subpkgdir"/usr/share/licenses/$pkgname/LICENSE
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ rm -rf "$pkgdir"/usr/share/doc # LICENSE and README.md
}
-md5sums="53fb6d1c375dd3ef8fff4ce2b7ff8f15 impacket-0.9.15.tar.gz"
-sha256sums="26af9c0734525448e4a8d56c9c7b05df0146497ec71101c33812f3f3503201eb impacket-0.9.15.tar.gz"
-sha512sums="1d061d19c873c58fc243bc0d49270d39a43fd3c82814862f1d4d1ac0241f162d1f3be765d0778243fd911736c4652dcdd7110ea5f86d1086b1829fa836f61b16 impacket-0.9.15.tar.gz"
+sha512sums="7707e7053de339f80167dc4f4846201db752cf260034eb74608092714a4587a2ab5fb04b73ca6440c91db8db227d7a9f7b70ad7e7fd48aa9057e45abe3f84a7d impacket-0.9.19.tar.gz"