aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-impacket
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 10:00:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 10:38:34 -0300
commit2f5d92fea96a332181a0e4eddce37963aa69fbd4 (patch)
tree4e9e82a852408b6791d2def3839e321d15927ae6 /community/py3-impacket
parent73952657d1f311dd001b21ae2508c6e110ba7d83 (diff)
downloadaports-2f5d92fea96a332181a0e4eddce37963aa69fbd4.tar.bz2
aports-2f5d92fea96a332181a0e4eddce37963aa69fbd4.tar.xz
community/py3-impacket: rename from py-impacket
Diffstat (limited to 'community/py3-impacket')
-rw-r--r--community/py3-impacket/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/py3-impacket/APKBUILD b/community/py3-impacket/APKBUILD
new file mode 100644
index 0000000000..59a3b6a936
--- /dev/null
+++ b/community/py3-impacket/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-impacket
+_pkgname=impacket
+pkgver=0.9.15
+pkgrel=1
+pkgdesc="A collection of Python classes providing access to network packets"
+url="http://code.google.com/p/impacket/"
+arch="noarch"
+license="Apache-2.0"
+depends=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages="py2-${pkgname/py-/}:_py2 $pkgname-doc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ install -Dm0644 "$builddir"/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+ depends="py2-asn1 py2-crypto"
+}
+
+doc() {
+ cd "$builddir"
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
+ mv impacket/testcases "$subpkgdir"/usr/share/doc/$pkgname
+ mv README.md "$subpkgdir"/usr/share/doc/$pkgname
+ install -Dm0644 LICENSE "$subpkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="53fb6d1c375dd3ef8fff4ce2b7ff8f15 impacket-0.9.15.tar.gz"
+sha256sums="26af9c0734525448e4a8d56c9c7b05df0146497ec71101c33812f3f3503201eb impacket-0.9.15.tar.gz"
+sha512sums="1d061d19c873c58fc243bc0d49270d39a43fd3c82814862f1d4d1ac0241f162d1f3be765d0778243fd911736c4652dcdd7110ea5f86d1086b1829fa836f61b16 impacket-0.9.15.tar.gz"