aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ipaddr
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-11 21:42:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 22:02:55 -0300
commit1eb49e0a2a2bf846ad7bd58a13d50c9dbbd315ac (patch)
tree9f90d0c75b65b786349c8c956a964978fb46a0f9 /community/py3-ipaddr
parent14f6dae46f88c13f99078035e6da0a33d749646d (diff)
downloadaports-1eb49e0a2a2bf846ad7bd58a13d50c9dbbd315ac.tar.bz2
aports-1eb49e0a2a2bf846ad7bd58a13d50c9dbbd315ac.tar.xz
community/py3-ipaddr: drop py2
Diffstat (limited to 'community/py3-ipaddr')
-rw-r--r--community/py3-ipaddr/APKBUILD41
1 files changed, 9 insertions, 32 deletions
diff --git a/community/py3-ipaddr/APKBUILD b/community/py3-ipaddr/APKBUILD
index a2d5d2fcdc..43cd3898ec 100644
--- a/community/py3-ipaddr/APKBUILD
+++ b/community/py3-ipaddr/APKBUILD
@@ -1,53 +1,30 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
-pkgname=py-ipaddr
+pkgname=py3-ipaddr
_pkgname=ipaddr
pkgver=2.2.0
-pkgrel=3
-pkgdesc="Python IP address manipulation library"
-url="http://code.google.com/p/ipaddr-py"
+pkgrel=4
+pkgdesc="Python3 IP address manipulation library"
+url="https://github.com/google/ipaddr-py"
arch="noarch"
license="Apache-2.0 PSF"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+depends="python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-ipaddr" # Backwards compatibility
+provides="py-ipaddr=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
- python2 ipaddr_test.py
python3 ipaddr_test.py
}
package() {
- cd "$builddir"
- python2 setup.py install --root="$pkgdir"
python3 setup.py install --root="$pkgdir"
}
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/$python* "$subpkgdir"/usr/lib/
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
sha512sums="5adb117c44e6e5dbdb9e96543aa7a34f35b4a4ec9baa163a25448058c34091bf4019d24f0250928291e4d4bc97dcdf75865daef739e2d94f98cc584e6e6c50dd ipaddr-2.2.0.tar.gz"