aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ipaddress
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:48:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-02 01:43:47 +0000
commitaad2afe051973fa7fd6f4f9b83703c09445ff17c (patch)
tree4266144bb0c3984f784b0dd910d33fa98a72c353 /community/py3-ipaddress
parentaad758e364da9a69d0d519b619cc6eb2c7d150f8 (diff)
downloadaports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.bz2
aports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.xz
community/py3-*: move from main/ and modernize
Diffstat (limited to 'community/py3-ipaddress')
-rw-r--r--community/py3-ipaddress/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-ipaddress/APKBUILD b/community/py3-ipaddress/APKBUILD
new file mode 100644
index 0000000000..f9d0a5977a
--- /dev/null
+++ b/community/py3-ipaddress/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-ipaddress
+_pkgname=ipaddress
+pkgver=1.0.23
+pkgrel=1
+pkgdesc="IPv4/IPv6 manipulation library"
+url="https://github.com/phihag/ipaddress"
+arch="noarch"
+license="Python-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-ipaddress" # Backwards compatibility
+provides="py-ipaddress=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="340e2a8698df1868038f55889671442eba17f06ec3f493759d8d0a9bf406eefbe1f67c14ca616f52e5bf2280942dcece7e89fb19de0923bee1ee20e60f48896e ipaddress-1.0.23.tar.gz"