aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ipython_genutils
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-03-17 21:54:44 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-04 06:04:24 +0000
commit2e387f0199e91137e01c9dfe2dad55cb2e029506 (patch)
tree1a4c505c1135ea8491f5607e1a27679fc8b1599c /community/py3-ipython_genutils
parent32c78abf1de20b0442b55d5893d32ac5383bea11 (diff)
downloadaports-2e387f0199e91137e01c9dfe2dad55cb2e029506.tar.bz2
aports-2e387f0199e91137e01c9dfe2dad55cb2e029506.tar.xz
testing/py3-ipython_genutils: move to community
Diffstat (limited to 'community/py3-ipython_genutils')
-rw-r--r--community/py3-ipython_genutils/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/py3-ipython_genutils/APKBUILD b/community/py3-ipython_genutils/APKBUILD
new file mode 100644
index 0000000000..63dde03c84
--- /dev/null
+++ b/community/py3-ipython_genutils/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=py3-ipython_genutils
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="Vestigial IPython utilities"
+url="https://github.com/ipython/ipython_genutils"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python3-dev"
+options="!check" # No test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython_genutils/archive/$pkgver.tar.gz"
+builddir="$srcdir/${pkgname#py3-}-$pkgver"
+replaces="py-ipython_genutils"
+provides="py-ipython_genutils"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="b238fce8ba437328b9cd78871cd8a8ab562c513d33db95be74296233114a39eb8a3b3c64fbfb149bc3d42d3eb7762defc03befb9862d6aefbaad389d2838f854 py3-ipython_genutils-0.2.0.tar.gz"