aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-isort
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-31 04:45:18 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 06:49:02 -0300
commitcd5a6cb44c5cc797977f56af4aa89229ae1508aa (patch)
treed7de55b6d194140b532db033af26054b48749722 /community/py3-isort
parent5f1983e52415d9ad2a26c3a6c2c4a4ae024e199f (diff)
downloadaports-cd5a6cb44c5cc797977f56af4aa89229ae1508aa.tar.bz2
aports-cd5a6cb44c5cc797977f56af4aa89229ae1508aa.tar.xz
community/py3-isort: upgrade to 4.3.21.2
Diffstat (limited to 'community/py3-isort')
-rw-r--r--community/py3-isort/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/py3-isort/APKBUILD b/community/py3-isort/APKBUILD
index cfdac35281..b9433da297 100644
--- a/community/py3-isort/APKBUILD
+++ b/community/py3-isort/APKBUILD
@@ -2,7 +2,8 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-isort
_pkgname=isort
-pkgver=4.3.21
+pkgver=4.3.21.2
+_tag=${pkgver%.*}-2
pkgrel=0
pkgdesc="Python library to sort Python imports"
url="https://github.com/timothycrosley/isort"
@@ -12,11 +13,11 @@ license="MIT"
options="!check"
depends="py3-setuptools"
makedepends="py3-pytest"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+source="$pkgname-$_tag.tar.gz::https://github.com/timothycrosley/isort/archive/$_tag.tar.gz"
+builddir="$srcdir"/$_pkgname-$_tag
-replaces=py-isort # Backwards compatibility
-provides=py-isort=$pkgver-r$pkgrel # Backwards compatibility
+replaces="py-isort" # Backwards compatibility
+provides="py-isort=$pkgver-r$pkgrel" # Backwards compatibility
build() {
python3 setup.py build
@@ -30,4 +31,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="2a35107baf7c78c03bab3ea2fadd0c6cbc8db219acd388600b01ace27c91e6c651355e1ecfeb03b1ef2893a1d066b3d2f182a0008e3c341193ac156b8aea0dc2 isort-4.3.21.tar.gz"
+sha512sums="fc2aa00c87196864864d2516b8be7acdedcf40d71d1931510e4b878dbd2b6da0b579661b50221f03f4aa5560c8bf23d5e1e10a2694d2b741ca09a92e40a4c687 py3-isort-4.3.21-2.tar.gz"