aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jedi
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 08:01:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-16 08:01:32 -0300
commit650e7578b7d3a85f4a773b1a4a235cbe0f005b1b (patch)
tree9c074d28c248d3a7efe3a435a1ca068163253185 /community/py3-jedi
parent8ae9b5757fd615a0e76a77f9c6f5dd17065884dd (diff)
downloadaports-650e7578b7d3a85f4a773b1a4a235cbe0f005b1b.tar.bz2
aports-650e7578b7d3a85f4a773b1a4a235cbe0f005b1b.tar.xz
community/py3-jedi: move from testing
Diffstat (limited to 'community/py3-jedi')
-rw-r--r--community/py3-jedi/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/py3-jedi/APKBUILD b/community/py3-jedi/APKBUILD
new file mode 100644
index 0000000000..416ddc53a6
--- /dev/null
+++ b/community/py3-jedi/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname="py3-jedi"
+pkgver="0.16.0"
+pkgrel=0
+_commit_typeshed="d38645247816f862cafeed21a8f4466d306aacf3"
+pkgdesc="Awesome autocompletion and static analysis library for Python"
+url="https://jedi.readthedocs.io"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://github.com/davidhalter/jedi/archive/v$pkgver/jedi-$pkgver.tar.gz
+ typeshed-$_commit_typeshed.tar.gz::https://github.com/davidhalter/typeshed/archive/$_commit_typeshed.tar.gz"
+options="!check" # Broken
+builddir="$srcdir/jedi-$pkgver"
+
+prepare() {
+ default_prepare
+
+ rmdir jedi/third_party/typeshed
+ mv "$srcdir"/typeshed-$_commit_typeshed jedi/third_party/typeshed
+}
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="000d5e7d9b45068ceba542635562e577208bb7cb0e0d91e3a3f3a671f8b8d89982a44979febce98cad2729aaf88e92805ee86caf94b14197b0d5e63910f5aa22 jedi-0.16.0.tar.gz
+bf49d25fb7ba4e6875480605386c37fadaa64ad6895b2ffb8432b0489f7b5848cdf1a10e586592610193ad5145461bf152e84443695e02303eaaa28fd3b55aa6 typeshed-d38645247816f862cafeed21a8f4466d306aacf3.tar.gz"