aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jinja2
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 11:54:26 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 13:00:03 +0000
commit22fa42a041a2c6bb4b8e5ce56ad2352e0f71024c (patch)
treeb22cc00f749aad8c06ce8bd6f891cfd9803a8884 /community/py3-jinja2
parent33f79d79324e93a03b65170b9f86394ac0003cd5 (diff)
downloadaports-22fa42a041a2c6bb4b8e5ce56ad2352e0f71024c.tar.bz2
aports-22fa42a041a2c6bb4b8e5ce56ad2352e0f71024c.tar.xz
community/py3-jinja2: moved from testing
Diffstat (limited to 'community/py3-jinja2')
-rw-r--r--community/py3-jinja2/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py3-jinja2/APKBUILD b/community/py3-jinja2/APKBUILD
new file mode 100644
index 0000000000..252576f5e1
--- /dev/null
+++ b/community/py3-jinja2/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-jinja2
+_pkgname=jinja
+pkgver=2.8
+pkgrel=1
+pkgdesc="small but fast and easy to use stand-alone template engine written in pure python."
+url="http://jinja.pocoo.org/"
+arch="noarch"
+license="BSD"
+depends="python3 py3-markupsafe"
+makedepends="python3-dev py-setuptools"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/pallets/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root=$pkgdir/ --optimize=1 || return 1
+}
+
+md5sums="4114200650d7630594e3bc70af23f59e py3-jinja2-2.8.tar.gz"
+sha256sums="e270c55a2736f39eee67daba60be64fe0790ccdbbc47cdcc3ebda3017981081f py3-jinja2-2.8.tar.gz"
+sha512sums="6ad1e0767f8e222f6a093a3e5d614f78e4d869d6971754b930f8b48fcea3fac5ae4b5e690c87d08485f5291525238e6f86a6e73d8aecaf6103bd71a62c792229 py3-jinja2-2.8.tar.gz"