aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-kiwisolver/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 01:40:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 01:40:44 -0300
commita4d6b01308ac922bd9cd9c6b52408366392129e6 (patch)
tree28d469349a61e86a6871cb97bdf81c0107657659 /community/py3-kiwisolver/APKBUILD
parent40c75c2796afce46a770b1102c87503f58c980e5 (diff)
downloadaports-a4d6b01308ac922bd9cd9c6b52408366392129e6.tar.bz2
aports-a4d6b01308ac922bd9cd9c6b52408366392129e6.tar.xz
community/py3-kiwisolver: move from testing
Diffstat (limited to 'community/py3-kiwisolver/APKBUILD')
-rw-r--r--community/py3-kiwisolver/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-kiwisolver/APKBUILD b/community/py3-kiwisolver/APKBUILD
new file mode 100644
index 0000000000..84a4da237c
--- /dev/null
+++ b/community/py3-kiwisolver/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py3-kiwisolver
+_pkgname=kiwisolver
+pkgver=1.1.0
+pkgrel=2
+pkgdesc="Efficient implementation of the Cassowary constraint solving algorithm"
+url="https://github.com/nucleic/kiwi"
+arch="all"
+license="BSD-3-Clause-Attribution"
+depends="py3-setuptools"
+makedepends="python3-dev"
+checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nucleic/kiwi/archive/$pkgver.tar.gz"
+builddir="$srcdir"/kiwi-$pkgver
+
+replaces="py-kiwisolver" # Backwards compatibility
+provides="py-kiwisolver=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$(echo $PWD/build/lib.*-3*)" py.test-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+
+sha512sums="e26a951fdba2fb221effe7ed785010d5795695b30e19fb67a30dc2ac883ee21b1daec967ad89734309c101513cd17bb5971118591270f402b8d46098178aff25 py3-kiwisolver-1.1.0.tar.gz"