aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ldap3/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 23:20:41 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 09:36:11 -0300
commit033a680859f21eec452752238b2831b250ab00eb (patch)
treefe9ea55997f7d075fe8accb6d1ed86cd837be393 /community/py3-ldap3/APKBUILD
parent5a1ff191fd1c1c143e37ee9e0f997372024c358d (diff)
downloadaports-033a680859f21eec452752238b2831b250ab00eb.tar.bz2
aports-033a680859f21eec452752238b2831b250ab00eb.tar.xz
community/py3-ldap3: rename from py-ldap3
Diffstat (limited to 'community/py3-ldap3/APKBUILD')
-rw-r--r--community/py3-ldap3/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/py3-ldap3/APKBUILD b/community/py3-ldap3/APKBUILD
new file mode 100644
index 0000000000..d4f8c48113
--- /dev/null
+++ b/community/py3-ldap3/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py-ldap3
+_pkgname=ldap3
+pkgver=2.6
+pkgrel=0
+pkgdesc="A strictly RFC 4510 conforming LDAP V3 pure Python client"
+url="https://github.com/cannatag/ldap3"
+arch="noarch"
+license="LGPL-3.0"
+depends="py-asn1"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-$_pkgname:_subpackage py3-$_pkgname:_subpackage"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cannatag/ldap3/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # tests need running LDAP server
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_subpackage() {
+ local pyver="${subpkgname:2:1}"
+ local python="python$pyver"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python ${depends//py-/py$pyver-}"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="1a1ded200f6c98a422f856b6b2295142acc8dc3b7bc2973c5cb8f54243d2769c5badc7707d965e51950610400c5fac2c823a543160e2bde405ea05fdb4aa8d91 py-ldap3-2.6.tar.gz"