aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-lz4
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 01:18:18 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 02:07:38 -0300
commit8e9322beab8dba3881aab32d9c0fde3641682e9f (patch)
treec895e175fd34eb3da64e47e991130e39c1032fd1 /community/py3-lz4
parent56c99d53f751420fee1457deb63b34d40c9962c8 (diff)
downloadaports-8e9322beab8dba3881aab32d9c0fde3641682e9f.tar.bz2
aports-8e9322beab8dba3881aab32d9c0fde3641682e9f.tar.xz
community/py3-lz4: rename from py-lz4
Diffstat (limited to 'community/py3-lz4')
-rw-r--r--community/py3-lz4/APKBUILD71
-rw-r--r--community/py3-lz4/system-libs.patch26
2 files changed, 97 insertions, 0 deletions
diff --git a/community/py3-lz4/APKBUILD b/community/py3-lz4/APKBUILD
new file mode 100644
index 0000000000..85e8bd7f75
--- /dev/null
+++ b/community/py3-lz4/APKBUILD
@@ -0,0 +1,71 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=py-lz4
+pkgver=2.1.9
+_pkgname=${pkgname#py-}
+pkgrel=0
+pkgdesc="LZ4 Bindings for Python"
+url="https://pypi.python.org/pypi/lz4"
+arch="all"
+license="BSD-3-Clause"
+makedepends="python2-dev python3-dev py-setuptools py3-setuptools lz4-dev linux-headers"
+checkdepends="py3-pytest py3-psutil py3-pytest-cov py3-coverage"
+
+# FIXME: check fails on s390x
+if [ "$CARCH" = "s390x" ]; then
+ options="!check"
+fi
+
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2 $pkgname-tests:_tests:noarch"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ system-libs.patch
+ "
+builddir="$srcdir/$_pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ rm lz4libs/lz4*.[ch]
+}
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$python $depends"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="py-future"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_tests() {
+ pkgdesc="$pkgdesc (tests)"
+
+ mkdir -p "$subpkgdir"/usr/share/$pkgname
+ mv "$builddir"/tests "$subpkgdir"/usr/share/$pkgname
+}
+
+sha512sums="e700e46ee873743f1e195ed8b5c6405a2535abf9f3d378e7d082e92e95ab9e00f5b93bfbe1634d504d1f293dd449ed280d6b6dc5c595d8fab87eefd6781ee99f lz4-2.1.9.tar.gz
+32928c49a6231106fbd7c73a1931c158a9d943132a22217e5f80ea0c20cc4a7259d9aca7dc5f7961b65e7e1e64f5740fd963f67d5078ebd9dec022fcbafa6181 system-libs.patch"
diff --git a/community/py3-lz4/system-libs.patch b/community/py3-lz4/system-libs.patch
new file mode 100644
index 0000000000..e746ac0241
--- /dev/null
+++ b/community/py3-lz4/system-libs.patch
@@ -0,0 +1,26 @@
+diff --git a/setup.py b/setup.py
+index 9fa3131..ad2f6a3 100644
+--- a/setup.py
++++ b/setup.py
+@@ -10,8 +10,8 @@ PY3C_REQUIRED_VERSION = '>= 1.0'
+
+ # Check to see if we have a lz4 and py3c libraries installed on the system, and
+ # of suitable versions, and use if so. If not, we'll use the bundled libraries.
+-liblz4_found = False
++liblz4_found = True
+ py3c_found = False
+ try:
+ from pkgconfig import installed as pkgconfig_installed
+ from pkgconfig import cflags as pkgconfig_cflags
+@@ -95,9 +95,7 @@ if compiler == 'msvc':
+ extra_compile_args = ['/Ot', '/Wall', '/wd4711', '/wd4820']
+ elif compiler in ('unix', 'mingw32'):
+ if liblz4_found:
+- extra_link_args.append(pkgconfig_libs('liblz4'))
+- if pkgconfig_cflags('liblz4'):
+- extra_compile_args.append(pkgconfig_cflags('liblz4'))
++ extra_link_args.append('-llz4')
+ else:
+ extra_compile_args = [
+ '-O3',
+