aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-msgpack
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-13 20:15:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-13 22:40:51 -0300
commit43ff74ccf444730ad67eba844d3a4377b9908563 (patch)
treef7aecbdcadbdd3db1a4acb60b30238d22a37d7fe /community/py3-msgpack
parent3b34f5d0c8e67275626b8362437ba4f4611a76ed (diff)
downloadaports-43ff74ccf444730ad67eba844d3a4377b9908563.tar.bz2
aports-43ff74ccf444730ad67eba844d3a4377b9908563.tar.xz
community/py3-msgpack: drop py2
Diffstat (limited to 'community/py3-msgpack')
-rw-r--r--community/py3-msgpack/APKBUILD33
1 files changed, 8 insertions, 25 deletions
diff --git a/community/py3-msgpack/APKBUILD b/community/py3-msgpack/APKBUILD
index 7b0750ddf1..b33f28db2b 100644
--- a/community/py3-msgpack/APKBUILD
+++ b/community/py3-msgpack/APKBUILD
@@ -1,22 +1,23 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-msgpack
+pkgname=py3-msgpack
_pkgname=msgpack-python
pkgver=0.6.1
-pkgrel=4
+pkgrel=5
pkgdesc="A Python module for MessagePack serialization/deserialization"
url="https://msgpack.org/"
arch="all"
license="Apache-2.0"
-makedepends="python2-dev python3-dev py-setuptools py3-setuptools
- cython2 cython3"
+depends="python3"
+makedepends="python3-dev py3-setuptools cython3"
checkdepends="py3-pytest py3-pluggy"
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
source="$_pkgname-$pkgver.tar.gz::https://github.com/msgpack/msgpack-python/archive/v$pkgver.tar.gz"
builddir="$srcdir/msgpack-python-$pkgver"
+replaces="py-msgpack" # Backwards compatibility
+provides="py-msgpack=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
@@ -34,25 +35,7 @@ check() {
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python=$1
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="cce526f103b0e2698e1d3931f34c18ebfe79dedd486aa3d051ce80b80e0fc73dc5961645205525002b24990b1c74cb17bee4be1b7d7a45fb232cbf108f929982 msgpack-python-0.6.1.tar.gz"