aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-multidict
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-22 10:05:47 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-22 10:07:44 +0100
commit090f4e3437af29ea826bdb9c0c23c2d9343a8813 (patch)
tree3c11db52bdd963b9eccecfe1d71bc9749f2b24f2 /community/py3-multidict
parent6a7b46fae4aa9b50730b395078caff246efe9d16 (diff)
downloadaports-090f4e3437af29ea826bdb9c0c23c2d9343a8813.tar.bz2
aports-090f4e3437af29ea826bdb9c0c23c2d9343a8813.tar.xz
community/py3-multidict: upgrade to 4.6.1
Diffstat (limited to 'community/py3-multidict')
-rw-r--r--community/py3-multidict/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/py3-multidict/APKBUILD b/community/py3-multidict/APKBUILD
index 5022a85743..a40ead1230 100644
--- a/community/py3-multidict/APKBUILD
+++ b/community/py3-multidict/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-multidict
_pkgname=multidict
-pkgver=4.5.2
-pkgrel=2
+pkgver=4.6.1
+pkgrel=0
pkgdesc="A multidict implementation"
url="https://github.com/aio-libs/multidict/"
arch="all"
license="Apache-2.0"
depends="python3"
-makedepends="python3-dev py3-setuptools"
+makedepends="python3-dev py3-setuptools cython"
subpackages="$pkgname-dev"
source="$_pkgname-$pkgver.tar.gz::https://github.com/aio-libs/multidict/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -20,11 +20,14 @@ check() {
}
build() {
+ (cd multidict && find -name '*.pyx' -exec cython {} \;)
python3 setup.py build
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
+ rm -f "$pkgdir"/usr/lib/python3*/site-packages/*.c
+ rm -f "$pkgdir"/usr/lib/python3*/site-packages/*.h
}
-sha512sums="ec66cf3c57e3386e07e45641536a6eeb94e9707d8a0d3b485d22b8687f20282c9115d533c7b0e9fb6dba28b923cf68dd8cdda08c75e78ca4eca2f0c3ec23c58f multidict-4.5.2.tar.gz"
+sha512sums="494075a9d567e8db6a2273d59957288ca0aedf083d25632791a94938bc41d31d5d8d4c7284240103a62bbbd46783e68a5b5247d88b7187b70fb28a868b6f0f2f multidict-4.6.1.tar.gz"