aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-natsort
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 21:11:09 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-28 21:11:09 -0300
commit27297e1c17e0805d49406e4bca78ceed89d8bb38 (patch)
tree8d4a7e81cfc34611928db2a84d92b8f0924a0473 /community/py3-natsort
parentd8eee36a1fea264a397ec9b725e2ff5200d919c8 (diff)
downloadaports-27297e1c17e0805d49406e4bca78ceed89d8bb38.tar.bz2
aports-27297e1c17e0805d49406e4bca78ceed89d8bb38.tar.xz
community/py3-natsort: rename from py-natsort
Diffstat (limited to 'community/py3-natsort')
-rw-r--r--community/py3-natsort/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/community/py3-natsort/APKBUILD b/community/py3-natsort/APKBUILD
new file mode 100644
index 0000000000..d5cfde04cf
--- /dev/null
+++ b/community/py3-natsort/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-natsort
+_pkgname=natsort
+pkgver=5.5.0
+pkgrel=1
+pkgdesc="A module for natural sorting"
+url="https://github.com/SethMMorton/natsort"
+arch="noarch"
+license="MIT"
+# Dependencies to run tests are not ready yet
+options="!check"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ pytest natsort
+ pytest-3 natsort
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="9d65c67bd9f441b1b0b16e048bc6ed6e9df21b8c18ae449ea0b86fec8c1c5a2f0d7bba0b8739481ed44ded1b5d692728ef1fca7c2b77cae272e729460d7eefed natsort-5.5.0.tar.gz"