aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ndg_httpsclient
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-25 21:31:01 +0300
committerprspkt <prspkt@protonmail.com>2019-07-25 21:39:38 +0300
commitc150418316312b670836b5ce55412a5a8f9af57b (patch)
tree559031924845fd05acda920ddaddee62990cfd22 /community/py3-ndg_httpsclient
parent174455672fa1f34cc8b0e070f7bebdf0f555efe2 (diff)
downloadaports-c150418316312b670836b5ce55412a5a8f9af57b.tar.bz2
aports-c150418316312b670836b5ce55412a5a8f9af57b.tar.xz
community/py-ndg_httpsclient: drop python2, adopt
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py3-ndg_httpsclient')
-rw-r--r--community/py3-ndg_httpsclient/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py3-ndg_httpsclient/APKBUILD b/community/py3-ndg_httpsclient/APKBUILD
new file mode 100644
index 0000000000..02394c3342
--- /dev/null
+++ b/community/py3-ndg_httpsclient/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-ndg_httpsclient
+_pkgname=ndg_httpsclient
+pkgver=0.4.4
+pkgrel=1
+pkgdesc="HTTPS client implementation for httplib and urllib2 based on PyOpenSSL"
+url="https://github.com/cedadev/ndg_httpsclient"
+arch="noarch"
+license="BSD"
+depends="py3-openssl py3-asn1"
+makedepends="py3-setuptools"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/cedadev/$_pkgname/archive/$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces=py-ndg_httpsclient # Backwards compatibility
+provides=py-ndg_httpsclient=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="604ea4a27915cd338549c0c51f5ec3419a56f1c24472b2ecded7cb7e9939a73b3b93cdbe0b62ea27793949aa035253f767f330ffcd8d1c044ae3516db99dc59c ndg_httpsclient-0.4.4.tar.gz"