aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-oauthlib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:48:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-02 01:43:47 +0000
commitaad2afe051973fa7fd6f4f9b83703c09445ff17c (patch)
tree4266144bb0c3984f784b0dd910d33fa98a72c353 /community/py3-oauthlib
parentaad758e364da9a69d0d519b619cc6eb2c7d150f8 (diff)
downloadaports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.bz2
aports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.xz
community/py3-*: move from main/ and modernize
Diffstat (limited to 'community/py3-oauthlib')
-rw-r--r--community/py3-oauthlib/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-oauthlib/APKBUILD b/community/py3-oauthlib/APKBUILD
new file mode 100644
index 0000000000..f767d8b8f8
--- /dev/null
+++ b/community/py3-oauthlib/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Eivind Uggedal <eu@eju.no>
+# Maintainer:
+pkgname=py3-oauthlib
+_pkgname=oauthlib
+pkgver=2.1.0
+pkgrel=3
+pkgdesc="Python3 implementation of the OAuth request-signing logic"
+options="!check" # requires 'blinker' that is in testing/
+url="https://github.com/idan/oauthlib"
+arch="noarch"
+license="BSD"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-nose py3-cryptography py3-jwt" # py3-blinker"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-oauthlib" # Backwards compatibility
+provides="py-oauthlib=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="bd749c7b65de00cc0c371053577623aca5767a0b20e41b2d5e3e20f8246e84bf360472b4ec983023227d6164ecd7ed4647c41cd8f425fe21200a2c25a9049ffd oauthlib-2.1.0.tar.gz"