aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-opengl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 15:55:01 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 16:09:06 -0300
commit59c7b9ad5d35ee95608354142da83844369aebd7 (patch)
tree74a0ec0551581ab9c2f494efc834fb1a67abf189 /community/py3-opengl
parent95a53f6f000e94a65987e782697039d30dd2cf71 (diff)
downloadaports-59c7b9ad5d35ee95608354142da83844369aebd7.tar.bz2
aports-59c7b9ad5d35ee95608354142da83844369aebd7.tar.xz
community/py3-opengl: rename from py-opengl
Diffstat (limited to 'community/py3-opengl')
-rw-r--r--community/py3-opengl/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/py3-opengl/APKBUILD b/community/py3-opengl/APKBUILD
new file mode 100644
index 0000000000..a6b8e08c59
--- /dev/null
+++ b/community/py3-opengl/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-opengl
+_pkgname=PyOpenGL
+pkgver=3.1.3b2
+pkgrel=1
+pkgdesc="Standard OpenGL bindings"
+url="http://pyopengl.sourceforge.net"
+options="!check"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="py3-setuptools py-setuptools"
+subpackages="
+ py3-opengl:_py3:noarch
+ py2-opengl:_py2:noarch"
+source="https://files.pythonhosted.org/packages/source/P/PyOpenGL/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="bc21e68ec6956b648725ac2db71435eb9cbe9925e52a5215dd553e2c933063f57e1ee44a48818b973be29160a00b03247c5e2157cf67e06b0d854d3dac369e80 PyOpenGL-3.1.3b2.tar.gz"