aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-opengl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 15:55:54 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 16:09:06 -0300
commit72aeafd82fe76d58a3d5da45724867aaea04b6ec (patch)
tree61b523194c6e299a8a5147b97b5ae7c889af3d0b /community/py3-opengl
parent59c7b9ad5d35ee95608354142da83844369aebd7 (diff)
downloadaports-72aeafd82fe76d58a3d5da45724867aaea04b6ec.tar.bz2
aports-72aeafd82fe76d58a3d5da45724867aaea04b6ec.tar.xz
community/py3-opengl: drop py2
Diffstat (limited to 'community/py3-opengl')
-rw-r--r--community/py3-opengl/APKBUILD36
1 files changed, 8 insertions, 28 deletions
diff --git a/community/py3-opengl/APKBUILD b/community/py3-opengl/APKBUILD
index a6b8e08c59..12c8af1e78 100644
--- a/community/py3-opengl/APKBUILD
+++ b/community/py3-opengl/APKBUILD
@@ -1,49 +1,29 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-opengl
+pkgname=py3-opengl
_pkgname=PyOpenGL
pkgver=3.1.3b2
-pkgrel=1
+pkgrel=2
pkgdesc="Standard OpenGL bindings"
url="http://pyopengl.sourceforge.net"
options="!check"
arch="noarch"
license="BSD-3-Clause"
-makedepends="py3-setuptools py-setuptools"
-subpackages="
- py3-opengl:_py3:noarch
- py2-opengl:_py2:noarch"
+depends="python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/P/PyOpenGL/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-opengl" # Backwards compatibility
+provides="py-opengl=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="bc21e68ec6956b648725ac2db71435eb9cbe9925e52a5215dd553e2c933063f57e1ee44a48818b973be29160a00b03247c5e2157cf67e06b0d854d3dac369e80 PyOpenGL-3.1.3b2.tar.gz"