aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pathlib2
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-26 19:38:41 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-09-30 19:50:57 +0000
commit8447eba86d77ff876f493f686f729b6a94d6f461 (patch)
tree2589a700c9fe539791b5153e8674e8731e9f03c3 /community/py3-pathlib2
parenta9da2cda9fdedf582761c122cff25c720509d87f (diff)
downloadaports-8447eba86d77ff876f493f686f729b6a94d6f461.tar.bz2
aports-8447eba86d77ff876f493f686f729b6a94d6f461.tar.xz
community/py3-pathlib2: move from main
Closes !175
Diffstat (limited to 'community/py3-pathlib2')
-rw-r--r--community/py3-pathlib2/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-pathlib2/APKBUILD b/community/py3-pathlib2/APKBUILD
new file mode 100644
index 0000000000..391df5fa50
--- /dev/null
+++ b/community/py3-pathlib2/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
+pkgname=py3-pathlib2
+pkgver=2.3.4
+pkgrel=1
+pkgdesc="Fork of pathlib aiming to support the full stdlib Python API"
+url="https://github.com/mcmtroffaes/pathlib2"
+arch="noarch"
+license="MIT"
+depends="python3 py3-six py3-scandir"
+makedepends="py3-setuptools"
+source="pathlib2-$pkgver.tar.gz::https://github.com/mcmtroffaes/pathlib2/archive/$pkgver.tar.gz"
+builddir="$srcdir/pathlib2-$pkgver"
+
+replaces="py-pathlib2" # Backwards compatibility
+provides="py-pathlib2=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="79b37a97037ba9ca2b315c7c4ff06e8b9b492d4f5d5cfe33e8b4cae533bf2314d27edb1a21f83791d82a1761df6a97bc07376cbff61e29e4bf43552daab499a0 pathlib2-2.3.4.tar.gz"