aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-peewee
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 01:40:25 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 01:40:25 -0300
commitc8332b29e0315dfc485ed1a35f9c94f34e956ae5 (patch)
tree68cf55748f4ab5795b3045d5a890858284603667 /community/py3-peewee
parentb95a02111cbc18c810d706c9c522af20674d1f23 (diff)
downloadaports-c8332b29e0315dfc485ed1a35f9c94f34e956ae5.tar.bz2
aports-c8332b29e0315dfc485ed1a35f9c94f34e956ae5.tar.xz
community/py3-peewee: move from testing
Diffstat (limited to 'community/py3-peewee')
-rw-r--r--community/py3-peewee/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/py3-peewee/APKBUILD b/community/py3-peewee/APKBUILD
new file mode 100644
index 0000000000..8c53f1ac24
--- /dev/null
+++ b/community/py3-peewee/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-peewee
+_pkgname=peewee
+pkgver=3.13.1
+pkgrel=0
+pkgdesc="A small, expressive ORM"
+url="https://github.com/coleifer/peewee"
+arch="all"
+license="MIT"
+depends="python3"
+makedepends="cython py3-setuptools python3-dev sqlite-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="34ee10adeb23ca109b6d35e57524504bb5f48d369220afa1027a8d7417583b55acd9d2515afce9b697ad0cde1596ea8cb6a4573d757b9c862941b3f1ed6bda9d peewee-3.13.1.tar.gz"