aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pem
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-06 21:01:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 21:01:12 +0100
commite609e944d671bc3ffaabb8b2c518039193f9e299 (patch)
treea680411381ec3635ffc0dabeb8a9f2225d86716b /community/py3-pem
parenta9819daf1b19e943648880deeb39219e970b9e64 (diff)
downloadaports-e609e944d671bc3ffaabb8b2c518039193f9e299.tar.bz2
aports-e609e944d671bc3ffaabb8b2c518039193f9e299.tar.xz
community/py3-pem: move from testing
Diffstat (limited to 'community/py3-pem')
-rw-r--r--community/py3-pem/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-pem/APKBUILD b/community/py3-pem/APKBUILD
new file mode 100644
index 0000000000..8e3c55e0c2
--- /dev/null
+++ b/community/py3-pem/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pem
+pkgver=19.3.0
+pkgrel=1
+pkgdesc="Easy PEM file parsing"
+options="!check" # Requires unpackaged pymodule 'pretend'
+url="https://pem.readthedocs.io/en/stable/"
+arch="noarch"
+license="MIT"
+depends="python3 py3-twisted"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-certifi py3-openssl"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hynek/pem/archive/$pkgver.tar.gz"
+builddir="$srcdir/pem-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0a5fae96ad2d8c80b4570f6cef9901045af00c6f8f28b751682097e5cfb2d4241212d7ca08292f4b704923073fb33d6b14a4c0532222d1f3e2ce77e73c49d8eb py3-pem-19.3.0.tar.gz"