aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-polib/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-26 08:05:49 +0300
committerprspkt <prspkt@protonmail.com>2019-07-26 08:14:12 +0300
commit560b42e861be431245cfa88e11715e7cb59a3674 (patch)
tree020cea020e4b42c76e92e8391b8e0d8e778d03ac /community/py3-polib/APKBUILD
parent5841fcdc82036705de82a96abf7a6d49ad70f4a4 (diff)
downloadaports-560b42e861be431245cfa88e11715e7cb59a3674.tar.bz2
aports-560b42e861be431245cfa88e11715e7cb59a3674.tar.xz
community/py-polib: drop python2
* Run test suite. Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py3-polib/APKBUILD')
-rw-r--r--community/py3-polib/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-polib/APKBUILD b/community/py3-polib/APKBUILD
new file mode 100644
index 0000000000..3dd8d99a43
--- /dev/null
+++ b/community/py3-polib/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-polib
+_pkgname=polib
+pkgver=1.1.0
+pkgrel=2
+pkgdesc="A library to manipulate gettext files"
+url="http://polib.readthedocs.org/en/latest/index.html"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces=py-polib # Backwards compatibility
+provides=py-polib=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 tests/tests.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="74681585b4d7252e107acd7d73f49f7e91c90adcd180722d39d35c40ec158434798af0124a16788cf564c73b84f52a040aefeb58355a1a3cd85848c3f6a5e67f polib-1.1.0.tar.gz"