aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-port-for
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-21 21:29:44 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-22 10:08:20 +0100
commita7b1a5803f71f7f36b0ad0cfef5c47ea9e8ff712 (patch)
treef5bae400f7de6adabc17659f530d902f187b31a2 /community/py3-port-for
parentc311034bc945258f1f47164692f4ee7c4b98c3a7 (diff)
downloadaports-a7b1a5803f71f7f36b0ad0cfef5c47ea9e8ff712.tar.bz2
aports-a7b1a5803f71f7f36b0ad0cfef5c47ea9e8ff712.tar.xz
community/py3-port-for: use --sitepackages for tox
Diffstat (limited to 'community/py3-port-for')
-rw-r--r--community/py3-port-for/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/community/py3-port-for/APKBUILD b/community/py3-port-for/APKBUILD
index a1a46dacaf..5d9ad12131 100644
--- a/community/py3-port-for/APKBUILD
+++ b/community/py3-port-for/APKBUILD
@@ -15,17 +15,14 @@ source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
- tox -e py3
+ tox --sitepackages -e py3
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}