aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-prompt_toolkit-gns3
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-02-12 08:49:55 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-02-12 08:49:55 +0000
commit17df3d3e8df25ebddee209ce243bed6f781e542e (patch)
tree067d0623e0593ccc54b2145df2b6a60ec7aacf36 /community/py3-prompt_toolkit-gns3
parent09f01fe2c9d0f28c976c757ad9a94523ae3026b0 (diff)
downloadaports-17df3d3e8df25ebddee209ce243bed6f781e542e.tar.bz2
aports-17df3d3e8df25ebddee209ce243bed6f781e542e.tar.xz
community/py3-prompt_toolkit-gns3: new aport for GNS3 only
Diffstat (limited to 'community/py3-prompt_toolkit-gns3')
-rw-r--r--community/py3-prompt_toolkit-gns3/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-prompt_toolkit-gns3/APKBUILD b/community/py3-prompt_toolkit-gns3/APKBUILD
new file mode 100644
index 0000000000..3d207f67d6
--- /dev/null
+++ b/community/py3-prompt_toolkit-gns3/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-prompt_toolkit-gns3
+_pkgname=prompt_toolkit
+pkgver=1.0.15
+pkgrel=0
+pkgdesc="Library for building powerful interactive command lines in Python - GNS3 compatible version"
+url="https://pypi.python.org/pypi/prompt_toolkit"
+arch="noarch"
+license="BSD"
+depends="py3-six py3-wcwidth python3"
+makedepends="python3-dev"
+conflict="py3-prompt_toolkit"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir"
+}
+
+sha512sums="10981be2ed8b71d0cd9f663c4de047cec9664d9276968c6eec40dc45b388d1acf8eba07d534369254f178931079bf39b04eb2ceac06aa63a2021ebf62387b2f5 py3-prompt_toolkit-gns3-1.0.15.tar.gz"