aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-prompt_toolkit/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-22 16:19:28 +0300
committerprspkt <prspkt@protonmail.com>2019-07-22 16:20:09 +0300
commit1e9b706c6b5dd59d8d441fb1aa21ef049702d02e (patch)
treeca25ce1385d6aeacab6f1eaaa584823c276c45c3 /community/py3-prompt_toolkit/APKBUILD
parent4a94d9925af0c8a8d4f66aa18723b62e61a5d4db (diff)
downloadaports-1e9b706c6b5dd59d8d441fb1aa21ef049702d02e.tar.bz2
aports-1e9b706c6b5dd59d8d441fb1aa21ef049702d02e.tar.xz
community/py3-prompt_toolkit: clarify license, modernize
Diffstat (limited to 'community/py3-prompt_toolkit/APKBUILD')
-rw-r--r--community/py3-prompt_toolkit/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/community/py3-prompt_toolkit/APKBUILD b/community/py3-prompt_toolkit/APKBUILD
index 70441e984a..fdc83951f2 100644
--- a/community/py3-prompt_toolkit/APKBUILD
+++ b/community/py3-prompt_toolkit/APKBUILD
@@ -3,32 +3,29 @@
pkgname=py3-prompt_toolkit
_pkgname=prompt_toolkit
pkgver=2.0.9
-pkgrel=1
+pkgrel=2
pkgdesc="Library for building powerful interactive command lines in Python"
url="https://pypi.python.org/pypi/prompt_toolkit"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
depends="py3-six py3-wcwidth"
makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces=py-prompt_toolkit # Backwards compatibility
provides=py-prompt_toolkit=$pkgver-r$pkgrel # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py check
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="8fd0f8f2d05ba81dbdd02e2885652dc8d4e756d3cfc57646328c6ebc3e0e38242604cadc72c7f2479850800c8f0e9f555ffab33df3061800f9a99744d857afd3 py3-prompt_toolkit-2.0.9.tar.gz"
+sha512sums="8fd0f8f2d05ba81dbdd02e2885652dc8d4e756d3cfc57646328c6ebc3e0e38242604cadc72c7f2479850800c8f0e9f555ffab33df3061800f9a99744d857afd3 prompt_toolkit-2.0.9.tar.gz"