aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pybind11/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-13 21:56:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-13 21:56:59 -0300
commit64fbb1faa2cea1d54f16589ef50097fed5c1c2a4 (patch)
treed10df68996e0b1f72e3b84e5c46b923f87b72f09 /community/py3-pybind11/APKBUILD
parentaceeedea27c36b0a60d5d6f3290b2dffc4f4a530 (diff)
downloadaports-64fbb1faa2cea1d54f16589ef50097fed5c1c2a4.tar.bz2
aports-64fbb1faa2cea1d54f16589ef50097fed5c1c2a4.tar.xz
community/py3-pybind11: fix location of cmake modules
Diffstat (limited to 'community/py3-pybind11/APKBUILD')
-rw-r--r--community/py3-pybind11/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/community/py3-pybind11/APKBUILD b/community/py3-pybind11/APKBUILD
index 98c98ab81c..5d831d3c31 100644
--- a/community/py3-pybind11/APKBUILD
+++ b/community/py3-pybind11/APKBUILD
@@ -2,7 +2,7 @@
pkgname=py3-pybind11
_pkgname=pybind11
pkgver=2.5.0
-pkgrel=0
+pkgrel=1
pkgdesc="Seamless operability between C++11 and Python"
url="https://github.com/pybind/pybind11"
arch="noarch"
@@ -30,11 +30,15 @@ build() {
python3 setup.py build
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
cmake -B build . \
-DCMAKE_BUILD_TYPE=None \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DUSE_PYTHON_INCLUDE_DIR=FALSE
+ -DUSE_PYTHON_INCLUDE_DIR=FALSE \
+ $CMAKE_CROSSOPTS .
make -C build
}
@@ -47,6 +51,9 @@ package() {
--install-headers=/usr/include/pybind11 --skip-build
make -C build DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/lib
+ mv "$pkgdir"/usr/share/cmake "$pkgdir"/usr/lib
}
dev() {