aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pybind11
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 15:02:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-03 02:22:03 -0300
commitcae2957d1fc1b04bdb69bdaa472526929b6452b2 (patch)
treea6527e9ab8cd28a265ffeb5a83af14fc0cbd27c1 /community/py3-pybind11
parent1c50666679a3f335d1f0cf9b5c9981c1fbe7ffe8 (diff)
downloadaports-cae2957d1fc1b04bdb69bdaa472526929b6452b2.tar.bz2
aports-cae2957d1fc1b04bdb69bdaa472526929b6452b2.tar.xz
community/py3-pybind11: modernize
Diffstat (limited to 'community/py3-pybind11')
-rw-r--r--community/py3-pybind11/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/community/py3-pybind11/APKBUILD b/community/py3-pybind11/APKBUILD
index 78128039f6..45c23507a8 100644
--- a/community/py3-pybind11/APKBUILD
+++ b/community/py3-pybind11/APKBUILD
@@ -2,7 +2,7 @@
pkgname=py3-pybind11
_pkgname=pybind11
pkgver=2.4.3
-pkgrel=2
+pkgrel=3
pkgdesc="Seamless operability between C++11 and Python"
url="https://github.com/pybind/pybind11"
arch="noarch"
@@ -30,24 +30,23 @@ build() {
python3 setup.py build
- mkdir -p "$builddir"/build-cmake
- cd "$builddir"/build-cmake
- cmake .. \
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_PYTHON_INCLUDE_DIR=FALSE
- make
+ make -C build
}
check() {
- make -C build-cmake check
+ make -C build check
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir" \
--install-headers=/usr/include/pybind11 --skip-build
- DESTDIR="$pkgdir" make -C build-cmake install
+ make -C build DESTDIR="$pkgdir" install
}
dev() {