aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyclipper
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-05-02 21:40:42 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-05-02 21:40:50 +0000
commit7bc5446db92045d221cce111232838068d3dd5e9 (patch)
treef3be3303a9a69f6b1e5368b42f5f5b055070acde /community/py3-pyclipper
parent7367db9f33c67a7144bd2198c40e4e9c99d19196 (diff)
downloadaports-7bc5446db92045d221cce111232838068d3dd5e9.tar.bz2
aports-7bc5446db92045d221cce111232838068d3dd5e9.tar.xz
community/py3-pyclipper: fix broken test that should be skipped
Diffstat (limited to 'community/py3-pyclipper')
-rw-r--r--community/py3-pyclipper/APKBUILD4
-rw-r--r--community/py3-pyclipper/disable-broken-test.patch14
2 files changed, 17 insertions, 1 deletions
diff --git a/community/py3-pyclipper/APKBUILD b/community/py3-pyclipper/APKBUILD
index 78b7268661..c64ca77821 100644
--- a/community/py3-pyclipper/APKBUILD
+++ b/community/py3-pyclipper/APKBUILD
@@ -16,6 +16,7 @@ makedepends="py3-setuptools python3-dev cython clipper-dev"
checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/p/$_pyname/$_pyname-$_pkgpostver.zip
10-system-libs.patch
+ disable-broken-test.patch
"
builddir="$srcdir/$_pyname-$_pkgpostver"
@@ -43,4 +44,5 @@ package() {
}
sha512sums="303be17e498f1d9fc5cdd0ce7c3e4c92c5d6dae7c7be7003402baa8403ec06951ec4805401748689e429118484cebaa6a762b8c2f4fc6ec801b4fd4a891131d9 pyclipper-1.1.0.post3.zip
-855d20489b4f7d90242ac2cb81b00b555d11925bf7c87d523a03ca3807fb1902d67a71645f7bc37f1997fd8bf779af06cb164f6de3a221149df7b69d4c2a283b 10-system-libs.patch"
+855d20489b4f7d90242ac2cb81b00b555d11925bf7c87d523a03ca3807fb1902d67a71645f7bc37f1997fd8bf779af06cb164f6de3a221149df7b69d4c2a283b 10-system-libs.patch
+06ced9f3410f436986109a7f0d54ccdd69597e75fb44c26d9dd1909b59a1a987f07ad55d2a0e24d114f2af31b3aa51cd6f44d7fe1658a625ac53e33bef379d8a disable-broken-test.patch"
diff --git a/community/py3-pyclipper/disable-broken-test.patch b/community/py3-pyclipper/disable-broken-test.patch
new file mode 100644
index 0000000000..b99d483061
--- /dev/null
+++ b/community/py3-pyclipper/disable-broken-test.patch
@@ -0,0 +1,14 @@
+Upstream: no
+Reason: the test should be skipped, but skipping is causing an error
+diff --git a/tests/test_pyclipper.py b/tests/test_pyclipper.py
+index 15f4f79..b2df1d0 100644
+--- a/tests/test_pyclipper.py
++++ b/tests/test_pyclipper.py
+@@ -408,6 +408,7 @@ class TestScalingFunctions(TestCase):
+ class TestNonStandardNumbers(TestCase):
+
+ def test_sympyzero(self):
++ return
+ try:
+ from sympy import Point2D
+ from sympy.core.numbers import Zero