aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyftpdlib
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-01-04 18:33:44 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-01-04 22:29:55 +0100
commit0524e9cfe60f9721e6a7f8825334821af9f5bf19 (patch)
treedb12fc40379ea10e27a0545b46f1a87906c685f8 /community/py3-pyftpdlib
parente3d010e890fef6d1cbeedf14c531b2af440c3cd1 (diff)
downloadaports-0524e9cfe60f9721e6a7f8825334821af9f5bf19.tar.bz2
aports-0524e9cfe60f9721e6a7f8825334821af9f5bf19.tar.xz
community/py3-pyftpdlib: move from testing
Diffstat (limited to 'community/py3-pyftpdlib')
-rw-r--r--community/py3-pyftpdlib/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-pyftpdlib/APKBUILD b/community/py3-pyftpdlib/APKBUILD
new file mode 100644
index 0000000000..595f3dd567
--- /dev/null
+++ b/community/py3-pyftpdlib/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer:
+pkgname=py3-pyftpdlib
+_pkgname=${pkgname#py3-}
+pkgver=1.5.5
+pkgrel=1
+pkgdesc="Extremely fast and scalable Python FTP server library."
+url="https://pypi.org/project/pyftpdlib/"
+arch="noarch"
+license="MIT"
+# v1.5.5 two failing tests https://github.com/giampaolo/pyftpdlib/issues/500
+options="!check"
+depends="py3-openssl py3-pysendfile"
+makedepends="py3-setuptools"
+checkdepends="py3-psutil"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="27427154f893812f689adf3a9ceb4ec2d8f0ea7a4bf7b08671dc146c95f09ddd596a27c85e009d8d6647277def48c0bf0a8b76fb3fba5818eda3dfdc6c10795e pyftpdlib-1.5.5.tar.gz"