aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pygit2
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-27 18:11:28 -0300
committerprspkt <prspkt@protonmail.com>2019-05-28 00:24:13 +0300
commit7ed3b924c77c18509ab30366c9d1cfd804898f5f (patch)
treef50262e13204ebd5feebfe478ac9d931c3dd8452 /community/py3-pygit2
parent5ac12acf6c0b70eacf3f9c4196fa02fb8e29cc85 (diff)
downloadaports-7ed3b924c77c18509ab30366c9d1cfd804898f5f.tar.bz2
aports-7ed3b924c77c18509ab30366c9d1cfd804898f5f.tar.xz
community/py3-pygit2: upgrade to 0.28.2
Diffstat (limited to 'community/py3-pygit2')
-rw-r--r--community/py3-pygit2/APKBUILD43
1 files changed, 11 insertions, 32 deletions
diff --git a/community/py3-pygit2/APKBUILD b/community/py3-pygit2/APKBUILD
index 0138e6b194..4bcf93de4c 100644
--- a/community/py3-pygit2/APKBUILD
+++ b/community/py3-pygit2/APKBUILD
@@ -1,53 +1,32 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Pierre-Gildas MILLON <pgmillon@gmail.com>
# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=py-pygit2
+pkgname=py3-pygit2
_pkgname=pygit2
-pkgver=0.28.1
+pkgver=0.28.2
pkgrel=0
pkgdesc="Python bindings for libgit2"
url="https://github.com/libgit2/pygit2"
arch="all"
-license="GPL-2.0-only-WITH-GCC-exception-2.0"
-depends="py-cffi py-six"
-makedepends="python2-dev python3-dev py-setuptools libgit2-dev"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+license="GPL-2.0 WITH GCC-exception-2.0"
+depends="py3-cffi py3-six"
+makedepends="python3-dev py3-setuptools libgit2-dev"
source="https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-pygit" # Backward compat
+provides="py-pygit=$pkgver-r$pkgrel" # Backward compat
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
- python2 setup.py check
python3 setup.py check
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="46bb9d6150b7413311f26ea1aeae15cdcd22a2d5c4cafa17bd8a1c02dbf0c9a630cf89583e77a07be5c74334ac28a672de31290ba986476ded25e8a19abf7f3b pygit2-0.28.1.tar.gz"
+sha512sums="3f742cdcc9d603c9cc9ef2e0a545da8bcfb555a0bdeea1c73c53a284b43d40ad6b28c87a029578ad7b1c8f2bf56ecd2859dac8dd836474bfc66223ff4af9e8f0 pygit2-0.28.2.tar.gz"