aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyhamcrest/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-22 22:25:01 +0300
committerprspkt <prspkt@protonmail.com>2019-06-22 22:29:02 +0300
commit9979f5b0b1f3c4f2ecb919758e3adc45b5e998dd (patch)
treeabab482a9018405bccd2c554793ea26e63abbdd1 /community/py3-pyhamcrest/APKBUILD
parent980d9e2ba1f25efb0a0b3453518c1ddb001e7c96 (diff)
downloadaports-9979f5b0b1f3c4f2ecb919758e3adc45b5e998dd.tar.bz2
aports-9979f5b0b1f3c4f2ecb919758e3adc45b5e998dd.tar.xz
community/py3-pyhamcrest: move from testing
Diffstat (limited to 'community/py3-pyhamcrest/APKBUILD')
-rw-r--r--community/py3-pyhamcrest/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/py3-pyhamcrest/APKBUILD b/community/py3-pyhamcrest/APKBUILD
new file mode 100644
index 0000000000..36e1a07a9b
--- /dev/null
+++ b/community/py3-pyhamcrest/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-pyhamcrest
+_pkgname=PyHamcrest
+pkgver=1.9.0
+pkgrel=2
+pkgdesc="Hamcrest framework for matcher objects"
+url="https://github.com/hamcrest/PyHamcrest"
+arch="noarch"
+license="BSD-3-Clause"
+depends="py3-six"
+makedepends="py3-setuptools"
+checkdepends="py3-hypothesis py3-mock py3-pytest"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/hamcrest/PyHamcrest/archive/V$pkgver.tar.gz
+ silence-warnings.patch"
+builddir="$srcdir/"$_pkgname-$pkgver
+
+replaces="py3-hamcrest" # Backwards compatibility
+provides="py3-hamcrest=$pkgver-r$pkgrel" # Backwards compatibility
+
+prepare() {
+ default_prepare
+ rm -f pytest.ini
+}
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="build/lib" py.test-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3a878637ed5138365416c170871a63640f089047b723c7ec8db893dd716c0b1cdad16a98584700405693b954af7d4868a8543d1a3fc58ded22b493c8c61661b4 PyHamcrest-1.9.0.tar.gz
+8320f8c832ed3f90c11242b3bd6fad2327b3d6d1cda9a025b80453a4e69a34d39d338a21601f412d4f1903eab74bf7217c21e5ac31f84091e2f11cf6369a5658 silence-warnings.patch"