aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyldap
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 12:13:14 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 12:26:45 +0000
commit3633e4d6db40e4d3a3027e2e20b6da2c1ad93c35 (patch)
tree676ff0ef8822656df0292221fa0f7c8428d8734b /community/py3-pyldap
parentbe37d7cf6f5b4db9ac366bf113a94fc22af7b752 (diff)
downloadaports-3633e4d6db40e4d3a3027e2e20b6da2c1ad93c35.tar.bz2
aports-3633e4d6db40e4d3a3027e2e20b6da2c1ad93c35.tar.xz
community/py3-pyldap: move to py3 only package
Diffstat (limited to 'community/py3-pyldap')
-rw-r--r--community/py3-pyldap/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-pyldap/APKBUILD b/community/py3-pyldap/APKBUILD
new file mode 100644
index 0000000000..9e44c5e729
--- /dev/null
+++ b/community/py3-pyldap/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py3-pyldap
+_pkgname=python-ldap
+pkgver=3.2.0
+pkgrel=0
+pkgdesc="Python modules for implementing LDAP clients"
+url="https://github.com/python-ldap/python-ldap"
+arch="all"
+options="!check" # depends on slapdtest
+license="Python-2.0"
+depends="libldap py3-asn1 py3-asn1-modules"
+makedepends="python3-dev py3-setuptools openldap-dev"
+checkdepends="openldap openldap-clients"
+source="https://github.com/$_pkgname/$_pkgname/archive/$_pkgname-$pkgver.tar.gz"
+replaces="py-pyldap"
+provides="py-pyldap=$pkgver-r$pkgrel"
+builddir="$srcdir/$_pkgname-$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="142ac4f98dfad62abb9ce47822771b4e431e4d86251f7139d99d92d0005cd6c2c1bec2b12e7ab96aa2f9d044e68623d4ddeecfc3a1820c19cd163ddd89355cd0 python-ldap-3.2.0.tar.gz"