aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pypeg2
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-09 10:16:43 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-09 10:16:43 +0100
commit8e96e3b30976328dd14362de93d010d9057313a8 (patch)
tree2535e94c85e98e5cf747c8250810614fdedbb55e /community/py3-pypeg2
parentcd91ae6fb0143c6834d77fa9ad259343bcd5887a (diff)
downloadaports-8e96e3b30976328dd14362de93d010d9057313a8.tar.bz2
aports-8e96e3b30976328dd14362de93d010d9057313a8.tar.xz
community/py3-pypeg2: move from testing
Diffstat (limited to 'community/py3-pypeg2')
-rw-r--r--community/py3-pypeg2/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-pypeg2/APKBUILD b/community/py3-pypeg2/APKBUILD
new file mode 100644
index 0000000000..91145e4f22
--- /dev/null
+++ b/community/py3-pypeg2/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Drew DeVault <sir@cmpwn.com>
+# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
+# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
+pkgname=py3-pypeg2
+_pkgname=pypeg
+pkgver=2.15.2
+pkgrel=5
+pkgdesc="An intrinsic PEG Parser-Interpreter for Python"
+url="https://fdik.org/pyPEG2/"
+arch="noarch"
+license="GPL-2.0-only"
+_gitrev="43b84d987ec1"
+depends="python3 py3-lxml"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/fdik/$_pkgname/get/$pkgver.tar.gz"
+builddir="$srcdir"/fdik-$_pkgname-$_gitrev
+
+replaces="py-pypeg2" # Backwards compatibility
+provides="py-pypeg2=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ make test PYTHON=/usr/bin/python3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="425e9f56c2353687ab0a77789c209359fd0cf50a949f39fea88c2e153737fbd4e7b0c9716895606a912fa4b98ced3380361739ebddeb13f60c6aad9e41a018d7 py3-pypeg2-2.15.2.tar.gz"