aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-localserver
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-05-12 15:21:44 +0100
committerprspkt <prspkt@protonmail.com>2019-06-21 02:06:05 +0300
commitfbba1fbd764fe8e8b33f75438d987c883c3ea5a7 (patch)
tree492f651ce3041221f3d8b05386908b822835e767 /community/py3-pytest-localserver
parent878e847d22737cb88db3368e19be826dfd97d297 (diff)
downloadaports-fbba1fbd764fe8e8b33f75438d987c883c3ea5a7.tar.bz2
aports-fbba1fbd764fe8e8b33f75438d987c883c3ea5a7.tar.xz
community/py3-pytest-localserver: from testing
Diffstat (limited to 'community/py3-pytest-localserver')
-rw-r--r--community/py3-pytest-localserver/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-pytest-localserver/APKBUILD b/community/py3-pytest-localserver/APKBUILD
new file mode 100644
index 0000000000..4061f5a968
--- /dev/null
+++ b/community/py3-pytest-localserver/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=py3-pytest-localserver
+_pyname=pytest-localserver
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="a pytest plugin to test server connections locally"
+url="http://bitbucket.org/pytest-dev/pytest-localserver/"
+arch="noarch"
+license="MIT"
+depends="python3"
+checkdepends="py3-pytest py3-six py3-requests py3-werkzeug"
+source="https://files.pythonhosted.org/packages/source/p/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+builddir="${srcdir}/${_pyname}-${pkgver}"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ pytest-3
+}
+
+sha512sums="aedf1e1c9563396457070df13df228ad0ebdd19173fa2ac5a598288d3e1a1ac8b8a0c0288cba0d8478e43d2e1de4848f2393bf640705916957f12ab31171c6cc pytest-localserver-0.5.0.tar.gz"