aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-xdist
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-29 15:13:48 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 16:53:52 -0300
commit96271a338ed11e00880554199ff0905e424b70d7 (patch)
tree68d89d77a9b306dc28119a74e1dc4a4cb26f0c88 /community/py3-pytest-xdist
parent6bba76739367303ac71c6f929d4e764e9557bfa8 (diff)
downloadaports-96271a338ed11e00880554199ff0905e424b70d7.tar.bz2
aports-96271a338ed11e00880554199ff0905e424b70d7.tar.xz
community/py3-pytest-xdist: rename from pytest-xdist
Diffstat (limited to 'community/py3-pytest-xdist')
-rw-r--r--community/py3-pytest-xdist/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/py3-pytest-xdist/APKBUILD b/community/py3-pytest-xdist/APKBUILD
new file mode 100644
index 0000000000..9bb11e0d3d
--- /dev/null
+++ b/community/py3-pytest-xdist/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
+# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
+pkgname=pytest-xdist
+pkgver=1.28.0
+pkgrel=0
+pkgdesc="pytest xdist plugin for distributed testing and loop-on-failing modes"
+url="https://github.com/pytest-dev/pytest-xdist"
+arch="noarch"
+license="MIT"
+depends="py-execnet pytest pytest-forked py-six"
+checkdepends="py-filelock py-py"
+makedepends="py-setuptools py3-setuptools py-setuptools_scm"
+subpackages="py3-$pkgname:_py3 py2-$pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ mkdir -p tmp_py2
+ python2 setup.py install --root="$builddir/tmp_py2" --optimize=1
+ PYTHONPATH="$builddir/tmp_py2/usr/lib/python2.7/site-packages:$PYTHONPATH" python2 -m pytest
+
+ mkdir -p tmp_py3
+ python3 setup.py install --root="$builddir/tmp_py3" --optimize=1
+ local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
+ PYTHONPATH="$builddir/tmp_py3/usr/lib/python$_py3ver/site-packages:$PYTHONPATH" python3 -m pytest
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="89b8885103a944ae72535de40028db052f76631ade6f969489d3dc3a1a61a3233df6655d0905d9f5253f23740a15aea824b460c680e79c16f275b31cb2abd6ad pytest-xdist-1.28.0.tar.gz"