aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytools
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 23:19:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 09:35:46 -0300
commita4faf3f1aec957beb934f0907afe04fa336911f9 (patch)
tree633427cc8e2558606f827760f75a82a9d8c79620 /community/py3-pytools
parentf785410d3316eedd8f8970d30cb73ed02487e91a (diff)
downloadaports-a4faf3f1aec957beb934f0907afe04fa336911f9.tar.bz2
aports-a4faf3f1aec957beb934f0907afe04fa336911f9.tar.xz
community/py3-pytools: move from testing
Diffstat (limited to 'community/py3-pytools')
-rw-r--r--community/py3-pytools/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/py3-pytools/APKBUILD b/community/py3-pytools/APKBUILD
new file mode 100644
index 0000000000..6c424bf2db
--- /dev/null
+++ b/community/py3-pytools/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pytools
+pkgver=2019.1.1
+pkgrel=0
+pkgdesc="Collection of tools for Python3"
+options="!check" # Tests required unpackaged dependencies not specified in requires.txt
+url="https://github.com/inducer/pytools"
+arch="noarch"
+license="MIT"
+depends="python3 py3-decorator py3-appdirs py3-six py3-numpy"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/inducer/pytools/archive/v$pkgver.tar.gz"
+builddir="$srcdir/pytools-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a2cf604151f866345cf986b77bca13f84f14a30947a23986b37bc2788f9c1da0c47459ce0cc149aa32daf1082d9cc29722e25ca459bee6d66f2fb1c43eb6a226 py3-pytools-2019.1.1.tar.gz"